Error: Outlet - Domain size of particles in direction Z is not zero

Hello everybody!

I encounter the following error, but do not understand, what the problem is:


this is the corresponding code:



I can’t find anything to help me in the documentation and do not understand what the error message is trying to tell me.
I don’t understand the relation between row 119 and the error message. The same command (row 130) leads to no problems for “outlet_back”
Just the “outlet_back”, which is quite similar, works fine, but the “outlet_front” works neither in combination nor by own its own.
The fact that the “z-size” of the outlet is 0 doesn’t appear to be the problem, as it works in “outlet_back”?!
My case limits should be big enough. (Again, I don’t understand what the error message is trying to tell me, so I’m checking whatever I can somehow try to relate it to)

definition dp="0.02" units_comment="metres (m)">
pointmin x="-0.1" y="-2" z="-0.1" />
pointmax x="6.9" y="7.5" z="1.1" />

Any ideas would be appreciated, thank you!

Comments

  • Hi,
    It looks like a FAQ-9 problem.
    https://dual.sphysics.org/index.php/faq/#Q_9

    Basically, the domain limits are used to generate particle but do not define the final limts of the simulation. When creating an inlet/outlet, only the surface is created at first. The layers of the inlet are created after, and can thus be outside the simulation domain.

    You can try to either manually define the simulation domain (see faq-9), or make sure at least one particle is generated past the future layer of you inlet/outlet.

    Best,
  • Hello TPouzol, thank you for your help.

    I was under the impression that I was already addressing that issue by using this code in the parameter section? (there are other particles being successfully generated at x="0" y="-1.5" z="0"with a dp=0.02 and 6 layers, it should only be 0.12 deep?!)


    Is simulationdomain (screenshot above) still referring to something different still than the FAQ)?
    If so, how/where in the code do I use the lines (below) provided in FAQ9. I find it very difficult to modify code without examples and these lines seem to be written in a style quite different to the rest of the xml code
    -domain_particles[:xmin,ymin,zmin,xmax,ymax,zmax]
    -domain_particles_prc:xmin,ymin,zmin,xmax,ymax,zmax
    -domain_fixed:xmin,ymin,zmin,xmax,ymax,zmax

    Also, what is the significance of the layer value? I randomly went with 6 as I saw it in on of the example cases.

    Thank you very much!
  • I've never used the simulation domain option. I think it should do the trick...
    You can check the actual domain limits in the out files I think.

    Concerning the layer, they determine the width of the buffer zone for Inlets
    see 4th dualsphysics workshop for more infos
    https://dual.sphysics.org/4thusersworkshop/data/_uploaded/PDF_Talks_4thWorkshop/Tafuni_Lisbon2018.pdf
  • edited June 13

    When you use a mkfluid to define the inlet/outlet zone using direction top or bottom, all particles with that mkfluid should be in the same Z, since it defines the first layer of inlet/outlet zone.
    The "drawbox" with "boxfill"=solid creates particles in several Z positions because "setdrawmode" mode="full" must be activated. The size.Z of "drawbox" is zero, so you can use "boxfill"=bottom or "boxfill"=top to solve this problem.
  • edited June 13
    Thank you guys for your responses!

    @TPouzol : Yes, turns out that it was another form of error. The possible solutions you were providing relate to "outside of domain" (or something similar, and had already been solved by using the "simulationdomain" command). Thank you none the less though.

    Regarding the layer: yes, I understand that it regulates the “thickness” of the layer, but can find info how creating a thin or thick layer affects the result/ what it means in the context ofr the simulation.

    @jmdalonso : Thank you so much! Turns out boxfill=solid is not a problem when the relevant axis size is set as zero, but I was able to solve it with this explanation.
Sign In or Register to comment.