IsoSurface: Segmentation Fault

On creating surface vtk files from binary files (each of 467 MB), ISOSURFACE stops with Segmentation Fault. What can be the reasons for this error. I saw a thread where this question was posted but no one replied a solution.


  • @Alex Please help me out on this one.
  • we need you send more information....
  • After binary files were created, i tried to generate vtk files by using the command 'IsoSurface_linux64 -onlytype:fluid -saveiso surface', but it ended with 'Segmentation Fault: core dumped'. I am using the official version of executable sent to me via link.
  • there is no need to add now "-onlytype:fluid"
    are you using the latest version 4.4? do you have the problem with that version?
  • Yes having problem with that version.
  • @Alex, urgently need a solution on this one. Ran this simulation for 14 days and have to study this results,
  • No worries, Problem solved. Broken File was the issue
  • @swaraj1112 can I send you a pm regarding your 14 days of simulation? I am just a bit curious, since I might soon have to look at something at a big scale as well. Is this your simulation with 300 million particles or something like that?

    Also happy you resolved your issue.

    Kind regards
  • It was Casting simulation (Liquid Metal Flow to the mould stl).
    Fluid Particles:14 mil
    Fixed Particles: 1.2 mil
    Simulation was done for 6 seconds. At first part generation was fast (in 15 mins) but later each part took 1 hour. Maybe there is auto time-stepping when convergence is not reached.
  • Correction: Simulation was set for 15 seconds.
  • Thank you! Kind of incredible what a single GPU can do, I imagine it must be some kind of a Quadro or?

    Hoping some day to get multi GPU support, would increase speed so much
Sign In or Register to comment.