CUDA driver version is insufficient for CUDA runtime version - code 35: Failed getting devices info

In my attempt to solve the problem of the watermill case crashing, I am trying to run it on my Mint Linux 19 box with GTX 650. However, when I run the code I get:

LoadDsphConfig> .../bin/linux/DsphConfig.xml
[Select CUDA Device]

*** Exception: Failed getting devices info. (CUDA error at FunctionsCuda.cpp:132 code=35(CUDA driver version is insufficient for CUDA runtime version)).

But I'm pretty certain I have the latest Nvidia driver for Mint 19, which according to the Nvidia x-server settings manager, is 390.116. Does this mean that a GTX 650 is now too old for this version of DualSPHysics?

Comments

  • What is the compute capability if your GPU card?

    Note that the GPU codes were compiled for compute capabilities sm30, sm35, sm50, sm52 sm61, sm70 and with CUDA v9.2

    So if you GPU card has a compute capability lower than 3.0 then you have to compile again the code for such capability

    Regards
Sign In or Register to comment.