: mkbound as an XML attribute does not support using a range

I had originally given that the following bug report here: https://github.com/DualSPHysics/DualSPHysics/issues/15 - and was later asked to report it here instead... so quoting from there:


Recently I've been testing DualSPHysics 4.3 beta and stumbled on the following situation:
<boundcorr>
<determlimit value="1e-3" comment="Use 1e-3 for first_order or 1e+3 for zeroth_order (default=1e-3)" />
<extrapolatemode value="3" comment="Calculation mode for rhop extrapolation from ghost nodes 1:fast-single, 2:single, 3:double (default=1)" />
<!-- direction is defined and limitpoint is calculated automatically (for sloping surfaces). -->
<mkzone mkbound="10-15">
<autolimitpoint dpfactor="0.5" comment="Point is calculated starting from bound particles at distance dp*dpfactor" />
<direction x="1" y="0" z="0" comment="Direction to fluid" />
</mkzone>
</boundcorr>

(edit: If the code is hard to see here, please check the original report.)

Notice the `mkbound="10-15"` entry for the `mkzone`. However, only after several simulations did I notice that it was only applying the setting to the first bound:

BoundCorr configuration:
DetermLimit....: 0.001 (1st order)
ExtrapolateMode: Double
MkZone_0 (mkbound:10)
Limit position.: (-0.255,0,-0.425) (automatic)
Fluid direction: (1,0,0)


I used this at first, because I thought that based on what other similar structures were using, e.g.:

<floatings>
<floating mkbound="0-3" relativeweight="0.5" />
</floatings>


or for example:

<properties>
<links>
<link mk="62-79" property="hard-wood+water" />
</links>
</properties>


Therefore, this report is to request that either:
1. The application complains and stops if it finds an unsupported range for at least the <boundcorr>.
2. Or that this range is also supported for <boundcorr>.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!