FloatingInfo4, error "Value PeriActive not found"

NOTE: I get the same error using BoundaryVTK4.

Transcript follows:

BoundaryVTK4 v4.0.014 (13-04-2016)

Input Files:
LoadVTK> Section_out/Section_Boat_Actual.vtk OnlyMk=[61]
LoadXML> Section_out/Section.xml

*** Exception (JBinaryData::CheckGetValue)
Text: Value PeriActive not found.


This is a 2D design, static stability on a boat section, less than 100k particles. I specified two particles for both boundaries and fluid points and a periodic boundary in Z:

XPeriodicIncZ" value="1.25"

At the moment I've go 'PosDouble" value="2"'. I think I've tried other combinations of single/double precision, but not sure.

Any suggestions? Is there a compatibility problem between these tools and a design with periodic boundaries?


  • XPeriodicIncZ value="1.25"
    it is not a periodic boundary in Z...
    it is a periodic boundary in X direction ... where particles that leave the domain in X+ appear at X- with same properties but with Zposition increased in 1.25

  • OK, you're right, I mispoke, my design has a periodic boundary in X with a Z offset.

    Anyway, my 2D simulations run and I can postprocess them with PartVTK4.
    I cannot run FloatingInfo4 or BoundaryVTK4 because I get the message "Value PeriActive not found".

    Does this message mean that XPeriodicIncZ is incompatible with FloatingInfo4 or BoundaryVTK4?

    Thank you.
  • Please use the latest version of BoundaryVTK...

    So use latest executables... since many bugs were solved.

    The new version of PartVTK4, FloatingInfo4 and BoundaryVTK4 is in the new package v4.2 (2018).

    And you are using BoundaryVTK4 v4.0.014 (13-04-2016)... from 2016 with new DualSPHysics executable of 2018. Please use versions of the same package


  • Alex,

    Good catch. The path link in my batch file pointed to the folder with the old executables. After that correction it works.

Sign In or Register to comment.