File of the particles was not found.

Hi Everyone,
After running GenCase, I try to run DualSPH and it shows the following Error.
*** Exception (JPartsLoad4::LoadParticles)
Text: File of the particles was not found.
File: temp17_14_12/z.bi4
But I checked the output folder, here referred as temp17_14_12 and it contains all the file. The snapshot of the folder contents are attached.What can be the issue.


  • No one can answer this?
  • Please can you paste here your script with the commands to run GenCase and DualSPHysics?
  • Sp = subprocess.Popen(args='"'+os.getcwd()+'"'+sphlocation+"\\"+"GenCase4_win64"+" "+output+" "+"temp"+ curr_time+"\\"+r"z -save:all", shell='TRUE', cwd = location)
    print 'Location of Duals = {0}'.format('"'+os.getcwd()+'"'+sphlocation+"\\"+"GenCase4_win64")
    Se = Sp.communicate()
    Sq = subprocess.Popen(args='"'+os.getcwd()+'"'+sphlocation+"\\"+"DualSPHysics4.2_win64"+" "+"temp"+ curr_time+"\\"+r"z -svres -cpu", shell='TRUE', cwd = location)
    Sf = Sq.communicate()
    Sr = subprocess.Popen(args='"'+os.getcwd()+'"'+sphlocation+"\\"+"PartVTK4_win64"+" -savevtk "+"temp"+ curr_time+"\\"+r"zPartFluid -onlytype:-all,+fluid -vars:+vol", shell='TRUE', cwd = location)
    Sg = Sr.communicate()
    Ss = subprocess.Popen(args='"'+os.getcwd()+'"'+sphlocation+"\\"+"IsoSurface4_win64"+" "+r"-onlytype:+fluid -vars:+vol -saveiso surface" ,shell='TRUE', cwd = location)
    Sh = Ss.communicate()
  • I expected that you use the script files we provided as examples... so that
    wCase.bat for windows and xCase.bat for linux.

    What are you using instead?
  • These are the same commands as mentioned in the batch files. I just wrote those in python to automate the process. Anyway this problem was arbitrarily solved, when i ran the simulation second time.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!