Boundary particles moving out of the domain

edited February 2018 in DualSPHysics v4.2
From the FAQs I coul see the following

The domain is fixed as a function of the initial article positions and modified for xmin,...
The values in proportion with the case dimensions according to the initial particles.
The domain is fixed with the specified values.

1.What is the difference between the first two commands viz: -domain_particles and -domain_particles_prc?
2.Are these to be supplied while executing the gencase or the batch file or both?
3. There was another option called 'draw point' instead of point min and point max , where/ how to use that?

Any general help to tackle the problem will also be appreciated
Thanks a lot


  • Threads by host for parallel execution: 8

    [Initialising JSphCpuSingle v0.70 20-02-2018 18:18:34]
    **Basic case configuration is loaded
    **Special case configuration is loaded
    Loading initial state of particles...

    *** Exception (JBinaryDataArray::GetDataCopy)
    Text: There are not available data in Pointer or FileData.

    Execution aborted.
    Press any key to continue . . .

    I'm alternating between these two errors, this one and the boundary particle moving out, can any one please help me out
  • Please check first the particles created by GenCase
  • Alex, thanks alot for your reply, I solved my boundary particles moving out, now my fluid particles are flowing down the beach (made using prism command) and getting emptied as if there is a hole.The same error persist even when I replace the prism with beach command.I'm scanning the whole code for any open boundaries but couldn't find any.I'm doing the case wave generation with a jacket surrounded by water and subjected to waves
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!