Restarting Simulation

edited February 2018 in DualSPHysics v4.2
I followed the user guide's instruction to restart a simulation on GPU, but it did not work properly. The simulation aborted showing an error msg "can't find Part_0000.bi4". So I copied that file and reran the simulation. After multiple attempts with copying few other files, the simulation was completed but it could not compute the motion of my floating object saying "Part not found". I tried running the FloatingInfo executable separately and got the same error. Anyone encountered this problem? Any suggestions?


  • You do not have to copy any file...
    What you have to do is to rename the folder with first part of the simulation (instead of usual Case_out... Case_out_BEFORE) so that the automatic name "Case_out" will be used for the second new folder.

  • Thanks for your response. Unfortunately, I still have the same problem. Following error msg occurred:

    Text: File of data not found
    File: Case_out/Part_0000.bi4
    Execution aborted.

    It seems like it can not get the Part_0000.bi4 file from my Case_out_before folder for any reason. So I manually copied the file to the newly created Case_out folder while the simulation was running. It worked but got another error msg:

    Text: PART not found.
    Execution aborted.

    By the way, I am using v4.0, not 4.2. I wrongly categorized this thread under v4.2.

  • *** Exception (JBinaryDataArray::GetDataCopy)
    Text: There are not available data in Pointer or FileData.

    Execution aborted.
    Press any key to continue . . .

    I also get this error on rerunning my simulations with changed parameters looks like the programme cannot get the binary file, never faced this problem earlier, always used to do resimulations and the OUT files were overwritten with new data
  • You can not restart a simulation changing parameters....

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!