Measuring Tool questions

edited November 2017 in DualSPHysics_v4.0

First of all I have to thank you because every time I've posted a question I've received a quick and useful answer from the people at dualsphysics so I just want to say I appreciate that.

Now, I've been having some doubts with the measuring tool, specifically with getting the max height. I tried using the commands on the HELP file, but I just can't seem to get it right. Whenever I use -height[:] with my points file I get the height for the points I have. So for example, if I have the point 0,3,2 I'll just get height 2 for every time step which makes sense, but is not what I'm after. Tried the same with -heightlimit:. So my question here is how do I input my command so that I get the max height.

Moreover, I don't really understand the use of -particlesmk: because I was asked for an xml file everytime I used that command and I'm not sure how a template for this would look or how I am supposed to input such file. Same happened while trying to calculate mass.

Son to summarize it, I want to calculate max height and mass, but I'm haven't figure out how. I have tried, however.

Thank you again!


  • You have to follow our examples.
    In order to compute -height you always have to define a list of points: POINTSLIST in the text file
    #BeginX BeginY BeginZ
    #StepX StepY StepZ
    #CountX CountY CountZ

    I short explanation can be found in PostprocessingCalculations_v4.pdf:
    To compute maximum height the tool will evaluate values of mass at a column of points for each X,Y position.

  • edited November 2017
    I have been trying to use the measure tool again I just can't seem to get it working. I have used it previously but now I'm using it again and I just keep running into the same error

    I use the following command
    EXECS\MeasureTool4_win64.exe -points Casos\Rectangular\Resultados\puntoslista -savecsv Casos/Resultados/Resultados.csv -dirin Casos\Rectangular\Resultados

    Just to try and get some results and I keep getting the following error
    Text: Variable 'Pos' is not defined in list of valid variables [Idp,3:Posd,3:Vel,Rhop,Press,Mass,Vol,Type,Mk,3:Ace,3:Vor,Kcorr].

    I tried giving it an specific variable as well adding -vars:press at the end but still got the same error
  • Just to try and get some results and I keep getting the following error
    Text: Variable 'Pos' is not defined in list of valid variables [Idp,3:Posd,3:Vel,Rhop,Press,Mass,Vol,Type,Mk,3:Ace,3:Vor,Kcorr].

    That error is solved in the v4.2, that will be release before the end of the year

  • Thanks

    Is there anyway I can change my inputs or is it just a random error? Because otherwise I am not able to get results
  • Hi
    I am relatively new to DualSPHysics and i have the same problem with measure tool (DualSPHysics V4).
    when I run the code on my Laptop (with a Nvidia Gforce GT 635M) it takes more time (about one day) to run, but the run finishes without any error. when I run the code on a more powerful PC (with a Nvidia Geforce GTX 1060 6 GB), the run finishes faster (about 4 hours), but it encounters an error at the end of the run (I can have Paraview representation of the simulation, the problem is just related to measuretool) . I don't know if this problem is solved in V4.2 or not.
    I appreciate any idea to solve the problem.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!