Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Restart exception Text: PART not found
  • Dear DualSPhysics users,

    While attempting to hot start CPU DualSphysics with the following command
    $dualsphysics $dirout/$name $dirout -svres -cpu -partbegin:43[:44] $dirout

    the following error occurs
    *** Exception (JPartFloatBi4Load::LoadPart)
    Text: PART not found.

    Can anyone help me understand what is wrong?

    Thank you,
    Jeremy
  • You have to indicate the proper directory where PARTs are:

    $dualsphysics $dirout/$name $dirout -svres -cpu -partbegin:43[:44] $dirOLD
  • Hello Alex,

    Thank you for helping me with this. I copied the _out directory to another directory and renamed it as OLD. I then use the command
    $dualsphysics $dirout/$name $dirout -svres -cpu -partbegin:43[:44] $current/OLD
    but get the same error
    *** Exception (JPartFloatBi4Load::LoadPart)
    Text: PART not found.

    I think it is finding the .bi4 file, because if I purposely enter a typo into the OLD directory name, like OLDa, it gives a different error
    *** Exception (JPartsLoad4::LoadParticles)
    Text: File of the particles was not found.
    File: /home/bricker/DualSPHysics_v4.0_Linux_x64/RUN_DIRECTORY/10_CASEDEM/OLDa/Part_0043.bi4

    Removing the typo, it looks like it is indeed reading the Part_0034.bi4, so am I missing something else?

    Thank you,
    Jeremy
  • $dualsphysics $dirout/$name $dirout -svres –gpu –partbegin:69 dirbegin

    restarts the simulation from the time corresponding to files output Part0069.bi4 located in the directory dirbegin

    If you still have problems, please send it to us (dualsphysics@gmail.com) and we will check it ASAP

    Alex
  • Hi Alex. Thank you for being helpful on this. I still get the same error, despite the presence of the Part0043.bi4 file in the input directory. I will email you my setup scripts today.
    Thank you.
    Jeremy
  • Hi bricker, hi Alex,

    I got the same error today. dualsphysics does indeed find the Part_0200.bi4 file (if I i.e. rename that file, a different error shows up), but I get the same error as bricker. Did you find out why the error is showing up?

    Thank you and best wishes
    Basti
  • Hi Basti,
    I never solved that one. Alex tried it on his machines, and it worked fine for him, so maybe it's specific to my (and your) system. I'm using Ubuntu 14.x LTS with the CPU version of DualSPhysics.
    Jeremy
  • Hi,
    I had the same problem. If your output files are named e.g. "Part_0001.bi4" a simple solution might be to use:

    –partbegin:Part_0069 instead of -partbegin:69

    That works for me :)

    Best
    Jan

    - Sorry, did not work. I get no error message but the computation starts from the very first timestep anyway -