Small scale simulation - increased time to solve?

edited October 4 in DualSPHysics v4.2
Hello guys!

I am trying to replicate this small scale simulation:




Where the ball is very tiny, d = 0,11 mm. I've done this by editing a test case provided by DualSPHysics and in the end I end up with a total of 16000 particles. For some reason it takes 10 minutes to solve each part, where before (the non edited case) it would be done in 1 min pr. part. For some reason it is doing 190000 steps instead of 90 steps as before.

Have anyone experienced and /or solved this? I've been try looking into tweaking the constants, but having some difficulties of where to start.

Kind regards

Comments

  • Another problem is that the ball won't fall down if I change the dimensions?



    So I made everything a lot smaller and changed the relative density of the ball to 2.37 (and increased allowed max rho to 2500 kg/m^3) but it just won't move? After 1 second of simulation time it tells me the ball was excluded from simulation.
    cd.PNG 12.9K
  • did you check your write intervall ??? of your very small case ???
    what is your CoefDtMin ???
    what is your cfl ??? try 0.2
    are us using sps or the artificial viscosity ??? - I had problems with the sps with smaller scales ...
    are all settings set to auto at the beginning of your case_def ???
  • Hello Hansoloo!

    1. I am not sure what is meant with write interval?

    2. CoefDtMin is 0.05 as default
    3. Cfl is 0.2
    4. I was using SPS - test with artificial viscosity now
    5. I've set most of them to automatic, I have uploaded my xml here if you want to help me take a look

    Thanks for your time

  • A small update

    I followed hansoloo's recommendation and my study could run now! Still having a hard time understanding why it won't work with SPS though. But why is the density of my floating = 1000? I specify relative density as 2.37 but it does not change..
  • Hi ... sorry for the late reply ... I did not get a notification that you replyed in the forum.

    For your xml you still could set the speed of sound also to auto = true.
    Maybe you set the hswl value to zero and auto = true, because as I remember it correctly 0.8 has a special meaning just check the FAQ page of DUALSPHYSICS. You could lower your coef of sound to 20, with 30 I oberved that becomese a bit more compulational intensive and the solution does look very "incompressible" or lets call ist blocky instead of a value of 20.

    For your last question I just double checked your xml again, and it seems that you are in a very small scale. So You probably have a foating point issue because the floating bodies are programmed with floats, just check the code. You can try your model with a sps case without floatings and it should run ...
  • Thanks for your suggestion Hansolooo and past experiences. I think the floating point issue might be one of the reasons the SPS scheme is having some difficulties.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!