Problem using -partbegin with periodic boundary conditions

edited February 8 in DualSPHysics_v4.0
Greetings,

After running DualSPHysics for 40 seconds (let's call this "Run A" ), I am running DualSPHysics again for another 40 seconds (let's call this "Run B") using the last timestep of Run A as the first timestep of Run B via the partbegin option.

Run A has a TimeOut of 0.1 and TimeMax is 40 seconds, so 400 bi4 files are produced. The directory where the new results for Run B will be stored is declared as a variable ("dircontinue") in the batch script, so DualSPHysics is called as folows:

%dualsphysics% %dirout%/%name% %dircontinue% -svres -gpu -partbegin:Part_0400 %dirout%

DualSPHysics gets far enough to show "PartBegin=400" in the output, but after the "Loading initial state of particles..." message, I get an error from JPartsLoad4:

[Initialising JSphGpuSingle v0.70 07-02-2018 10:57:50]
PartBegin=400
PartBeginDir="CaseBoom_out"
PartBeginFirst=400
**Basic case configuration is loaded
**Special case configuration is loaded
Loading initial state of particles...

*** Exception (JPartsLoad4::CheckConfig)
Text: Data file does not match the periodic configuration of the case.


I have periodic BCs in both the x and the y for both Run A and Run B, which both use the same CaseDef XML. If I turn off the periodic BCs in the CaseDef, Run B does run, but I need the periodic BCs. I'm not sure if this is a bug or user error, but if anyone can provide guidance about how to get past this problem, I would be most grateful.

-Nick

Comments

  • Hi,

    I also had that issue ... as far as I remember there is a bug related to loading cases with X and Y periodics... it was somewhere written in the forum ... but I cant find it right now ... best H
  • That was an error that we tried to solve in v4.2
    Please Nick, can you tell me if the error still appears in the beta version of 4.2

    Alex
  • I ran it in v4.2 (171110 beta) and it works! Many thanks for the code improvements and for suggesting that I run it in the latest version.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!