particle boundary out

edited July 2017 in DualSPHysics_v4.0
Hi

I am trying to simulate a sloshing tank with linear harmonic motion based on the example given in 5_CASESLOSHING, but I keep getting a error: "Some boundary particle was found outside the domain." with following errors preceding in run.out:
"...
particle boundary out> type:Moving cause:Speed p:2 id:3 pos:(-0.704000,0.000000,0.002000)
particle boundary out> type:Moving cause:Speed p:3 id:74 pos:(-0.702000,0.000000,0.000000)
particle boundary out> type:Moving cause:Speed p:4 id:76 pos:(-0.700000,0.000000,0.000000)
particle boundary out> type:Moving cause:Speed p:5 id:78 pos:(-0.698000,0.000000,0.000000)
..."

Which makes no sense since the domain is way bigger:
"MapRealPos(final)=(-0.90013,-0.00013,-0.10013)-(0.90013,0.00013,0.24213)"

If I simulate the sloshing until the point of the error I get the following behaviour:
https://www.dropbox.com/s/borhanezojry7c4/sloshfail.gif?dl=0 (GIF)
where I see no reason for sudden errors.

What is causing the problem?

Comments

  • edited July 2017
    I have already made two "drawpoint" (if you look closely you can see them in the GIF), with the following command:
    "
    setmkbound mk="2"
    drawpoint x="-0.9" y="0" z="-0.1"
    drawpoint x="0.9" y="0" z="0.242"
    "
    and the 2D sloshing tank is only oscillating between +/- 0.708 in the x-direction (only movement there is).
  • Hi

    Please increase the x and z of the these two points, so your domain should be larger.

    Let me know if this helps!
  • Is the domain not what is described under "MapRrealPos", as written in my original post? Anyhow, I increased x and z of the two points and saw unfortunately no change in outcome.

    Since there is no way to attach files in the forum(?), I have copied the most important from the .xml file:
    "...
    geometry>
    definition dp="0.002" units_comment="metres (m)">
    pointmin x="-2" y="0" z="-1" />
    pointmax x="2" y="0" z="1" />
    /definition>
    commands>
    mainlist>
    setshapemode>dp | bound
    setdrawmode mode="full" />
    setmkbound mk="0" />
    drawbox>
    boxfill>all
    point x="-0.705" y="-0.1" z="0" />
    size x="1.410" y="0.2" z="0.142" />
    /drawbox>
    setmkfluid mk="0" />
    fillbox x="0" y="0" z="0.02">
    modefill>void
    point x="-0.705" y="-0.1" z="0" />
    size x="1.410" y="0.2" z="0.05" />
    /fillbox>
    shapeout file="" />
    setmkbound mk="2" />
    drawpoint x="-1.3" y="0" z="-0.5" />
    drawpoint x="1.3" y="0" z="0.642" />
    /mainlist>
    /commands>
    /geometry>
    motion>
    objreal ref="0">
    begin mov="1" start="0" finish="100" />
    mvfile id="1" duration="100">
    file name="TankMotion.txt" fields="2" fieldtime="0" fieldx="1" />
    /mvfile>
    /objreal>
    /motion>
    ..."

    The TankMotion.txt holdes the displacement for a harmonic sinusoidal motion with a amplitude of 0.03.
  • Please upload the .xml file and also the TankMotion.txt in google-drive or dropbox. I will work on it.
  • Hi
    I have solved the problem and I have modified these 2 files. I have tested it and it worked with NO problem.
    Please use these files:

    https://uploadfiles.io/jzbez

    https://uploadfiles.io/ls99j
  • Thank you for the help. You are right it works now, but I am curious to why. I noticed that you have changed 3 things:
    1) Expanding the domain (pointmin/max, drawpoint)
    2) Changed the boundary and fluid label from 0 and 1 to 60 and 0
    3) Added a column with ones in the motion file

    I do not see how this should work and the original setting does not. Would you care to elaborate?
  • Ah!
    Try changing these parameters one by one. You will find the answer.
    There are some bugs in the code. I hope that the developers fix them as soon as possible!
  • Hi I'm facing the same problem

    "particle boundary out> type:Moving cause:Position p:3059 id:32247 pos:(-1.005213
    ,-0.350000,0.200000)

    *** Exception (JCellDivCpuSingle::LimitsCellBound)
    Text: Some boundary particle was found outside the domain."


    can you help me how to use draw point (where should that be written?)in this context or other options like -domain particle (I tried using them without any respite)

    I also tried increasing the domain without any change in results.

    Thanks in advance




  • edited February 20
    Threads by host for parallel execution: 8

    [Initialising JSphCpuSingle v0.70 20-02-2018 18:18:34]
    **Basic case configuration is loaded
    **Special case configuration is loaded
    Loading initial state of particles...

    *** Exception (JBinaryDataArray::GetDataCopy)
    Text: There are not available data in Pointer or FileData.


    Execution aborted.
    Press any key to continue . . .


    I'm alternating between these two errors, this one and the boundary particle moving out, can any one please help me out
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!